iPhone Screenshots

Description

Remotely control all the rear panel settings of the Turbosound iX & iP series speakers.

Because the speakers use Bluetooth 4 to communicate with the app, you will need an iPhone 4S or later, or an iPad 3 or later.

What’s New

Version 1.4.1

iPhone X support
Minor bug fixes

Ratings and Reviews

2.8 out of 5
24 Ratings

24 Ratings

who am i anyway ,

Works but could improve

Mine works fine. But I’d like to be able to Mute instead of having to turn volume all the way down. The sliders could be wider or more user friendly. I hope you improve the app cause this is a great feature for the system.

singbiosis ,

Functional, but not really usable

The existence of this app was part of what sold me on the TurboSound system, but I have been rather disappointed. It is true that, once paired, the app allows you to change settings, but I find myself exasperated every time I try to use it. I have resorted to using the on-device controls, which are annoying because of the many layers one has to navigate with one knob—still, it is better than this app. The app UI seems to be more focused on looking good for sales screenshots than on working well. Like other comments, I am bewildered that the level “faders” offer no numeric confirmation of the level you have set, and the graphic display does not seem to correspond with the actual level. It would be better to just let me type a level! I have been waiting nearly a year for what seems like an inevitable app update, since this version is pretty much unusable.

New iP300 user ,

It doesn’t work with iPhone 11 Pro Max

I down loaded the App. It works fir the first time. After that it doesn’t work any more. It keeps scanning and saying that “Your phone must be paired and connected with the speaker in your device’s Bluetooth setting” However, my iPhone is always connected with the iP300 speaker. I can stream music to the speaker all the time, but the App doesn’t work.

Information

Seller
Music Group Research UK Limited
Size
23.5 MB
Category
Music
Compatibility

Requires iOS 9.0 or later. Compatible with iPhone, iPad, and iPod touch.

Languages

English

Age Rating
4+
Copyright
Price
Free

Supports

  • Family Sharing

    With Family Sharing set up, up to six family members can use this app.

More By This Developer

You May Also Like